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Beginning Web Forms 
 
I.  Introduction to Forms 
 

A. Paper vs. Digital (Web forms) 
Regardless of format, the basic purpose of a form is to capture various types of information 
from one person that will in turn be sent to another person or organization in a logical, 
(preferably) easy-to-follow format. The standard paper form has been a fundamental part of 
office and business life for decades, gathering feedback for restaurants, placing subscriptions 
for print media, or ordering products from corporations. Clearly, the paper form will continue 
to have its uses in the foreseeable future. 
 
But in the increasingly complicated world of online communication, business, and 
information, Web forms are everywhere and can do anything imaginable from ordering a 
pizza on dominos.com (that will still be delivered in less than 30 minutes) to requesting 
information about an interesting college or university program. 
 
Web forms have succeeded in replacing paper forms (or even phone calls or trips to 
Domino’s) for three reasons: 
• Web forms are fast. Instead of looking through a catalog and using an order form to buy a new shirt, a 
person can go online, browse an entire inventory of shirts and buy a new shirt in 30 minutes, fractions of the 
time it would have taken for the paper order form to be mailed to some obscure city in a far away state. 
• Web forms are easy to use. (Note: That doesn’t not always mean they are easy to create!) Imagine 
that the hypothetical shirt company from above just received the paper order form from Joe in Tucson. It turns 
out that Joe has terrible handwriting, and they send him the completely wrong product. Now Joe’s angry, sends 
the shirt back, demands a refund, and vows not to ever order from a catalog again. Web forms obviously don’t 
have this problem, and they allow a user to make corrections to the information they type into the form without 
going to find the Wite-Out™. 
• Web forms are more cost effective (and environmentally friendly) than paper. 
Paper forms cost money to print. Over and over and over. Web forms are free to set up (not including any 
software that is purchase) and can run fine on most organizations’ existing Web servers. This is true for UTM – 
we already have everything needed to start using forms online while cutting down on printing costs. 
 
B.  Types of Web Forms. 
So as discussed above, Web forms have plenty of benefits over their paper cousins, but 
getting started with Web forms requires knowledge of more than just basic word processing 
or desktop publishing (as required for paper forms). There are several types of Web forms 
with varying uses and degrees of difficulty to create. These types include: 
• HTML forms sent to e-mail (covered in this handout) 
• PDF forms (covered in this handout) 
• HTML forms attached to a database, including Dragon WebSurveys, PHP, ASP, etc. (NOT 
covered in this handout) 
 
Forms tied to a database are beyond the scope of what most users at UTM need for their Web 
sites and are also beyond the scope of a single training session or handout and therefore will 
not be covered here. 
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II. HTML forms 
 
A. Requirements for HTML forms 
In terms of simplicity, HTML forms are the easiest types of forms to create with a little 
knowledge of a Web editing program. HTML forms can also be written by users with 
knowledge of the HTML scripting language in a Web editor or with a simple text editor. 
 
For a user with no knowledge of HTML, using a Web editing program such as Adobe 
Dreamweaver will allow the form creator to build a form through the use of menus which 
add the form features to a Web page without requiring the user to write any HTML. The 
downside to this method is the cost of Dreamweaver (the best Web editing software on the 
market). Less expensive software, including Adobe’s (formerly Dreamweaver’s) Contribute 
software does not allow the user to create forms or write HTML and thus is not useful for 
form creation. 
 
Thus, the minimum requirements for creating HTML forms are either a working knowledge 
of HTML or a What-You-See-Is-What-You-Get Web editing software program such as 
Dreamweaver. 
 
B. Creating an HTML form in Dreamweaver 
Assuming that a user who knows HTML does not need an explanation of how to write the 
code for a form, the following section will show how to create an HTML form using only the 
menus available in Adobe Dreamweaver for users who will only use its Design mode. 
 

Step 1. Create a new document. 
Open a new document in Dreamweaver from the File menu or by pressing Ctrl+N. 
Step 2. Create a new form. 
Click in the body of the Web page at the location where the new form will be inserted. Then create a new 
form by clicking the Insert menu (at the top of the screen) the Form > Form. 
 
 Adding a Form. 

Add a form to a Web 
page from the insert 
menu in Dreamweaver. 
This inserts a red 
rectangle into the body of 
the document where all 
of the form’s fields must 
be placed to work 
properly. 
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Step 3. Add fields to the form. 
After the form “rectangle” is added to the page from the Insert menu, click inside the red rectangle to add 
the inputs that a user will insert information. To add different inputs, go to the Insert menu and then to 
Form (see screenshot on Page 2 of this handout). On this menu, all of the different form field options are 
available to be added to the form. Click the type of field you want to add it to the page. If a box pops up 
asking you for a label, just click “Ok” with the default buttons checked on the pop. 
The most common form inputs are the text field, text area, button, checkbox, radio button, and list/menu. 
 

Different form fields on a Web page 
The text field is used for one line 
response such as Name or E-mail. 
The text area is useful for longer, multi-
line responses such as a paragraph for 
users’ comments about a service. 
Buttons are used to submit or reset the form. 
A checkbox is used when a user is 
allowed to check one or more options 
from a list (i.e., if they are selecting which 
sessions to attend from a list of five 
sessions on different days). 
A radio button is normally used with a 
group of other radio buttons when a user 
must choose only one option from the list 
(i.e., if they can only attend one of five 
sessions that occur simultaneously).  
Finally, a list or menu is used when the 
user must choose a response from a 
defined list of options. Menus allow for 
one choice; lists allows for multiple 
choices. 

 
Step 4. Name the fields. 
Once you have added the fields and questions to your form, it will look something like this: (Note: using a 
table to help organize the page will improve the appearance of the Web page.) 
 Does your 

form look like 
this? 
If the form you 
are working on 
doesn’t look 
very organize 
insert a table 
from the Insert 
menu and play 
around with 
putting the 
questions and 
fields in 
separate table 
cells. 
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After you get all the inputs on the page arranged as you want them, you will then have to name each input 
so that you will know which is which when the results are e-mailed to you. To name the input, click the box 
(or button, list, etc.) and the properties box at the bottom of the page will change to let you modify the 
options. 

Text Field 
The properties box at the 
bottom of the page 
changes from the default 
text properties box to the 
Text Field property box. 
To rename the field, 
click in the box on the 
left (outlined in red 
below) and rename the 
field. On this properties 
box, you also have the 
option of changing the 
length of the box (Char 
width field) and the 
maximum number of 
characters allow (if, for 
instance the user is 
limited to a 9 character 
pin number.) 
Note that changing a 
single line to a multi line 
will actually change the 
text field into a text area. 

 
 
 

Check Box 
The check box properties 
allows you to rename the 
check box and specify a 
value (yes, no, etc.) for 

that box. If the box is used to answer the question “Check here if you will be attending Session 1” the value 
you might consider using could be “yes.” You can also specify if the box will be checked automatically 
when the page loads. 

Radio Button 
The radio button 
properties works like the 
check box properties, 
except for radio buttons 
to work as a group (e.g., 
so users can only select 
one of the options) the 
name must be the same 
for each radio button in 
the group. Only the 

checked value changes between the buttons, as seen in the screenshot above. 
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Menu/List 
The menu or list 
properties box allows you 
to rename the menu/list 
just like other inputs, but 
also lets you select to 
make the input a list or a 
menu. A menu only 
allows for one selection; 
a list shows multiple 
choices and allows for 
multiple selections. 
The List Values… button 
lets you type in the 
choices a user will have. 
The Item Label is the text 
they will see in the form; 
the value is the text that 
will be e-mailed to you. 

Step 5. Setting the form to send. 
The final step in setting up a form is to set the action that will happen when the user hits the Submit button. 
This requires a separate file to process the form, and the one we use is a free PHP script from 
http://www.webligo.com/download.php?x=dyna. You will need to download the zipped file and then unzip 
the package. The most important file is the dyanform.php page which contains the instructions for how to 
set up the form processor. This file will need to be copied into the default Web folder for your Web site, 
and then opened in Dreamweaver. You will have to view the code to edit the file, but the instructions in the 
code are easy to follow. The main part you need to fill out is the e-mail address section where you will 
specify what e-mail to send the form results to. If you need help with the form processor, call the 
Instructional Technology Center 731-881-7877. 

After setting 
up the form 
processor, 
close 
dynaform.php 
and open the 
form page in 
Dreamweaver. 
You must 
specify where 
to find 
dynaform.php. 
You will need 
to view the 
HTML code, 
so click on the 
Split view. 
Find the 
beginning of 
the form code 

(it will be in orange text, by Dreamweaver’s defaults; see above for an idea of where the <form> code is) 
and click between the quotations marks after the word action. If dynaform.php will be in the same folder as 
the form page, type in dynaform.php. If dynaform.php is going to be kept in another Web folder, you will 
need to specify the address to the form (such as 
http://www.utm.edu/departments/ecce/webforms/dynaform.php). The only other aspect you might want to 
change is the name of the form, which defaults to form1. Finally, upload both pages to the Web server. 
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III. PDF Forms 
A. Uses of a PDF form 
A PDF form is a useful document that has both advantages and disadvantages over other 
types of forms. The PDF form is easier to create than an HTML form and requires no 
knowledge of scripting. The PDF form is also more secure than a Web-based form, as it is 
possible for a spammer to use a Web-based form to send false responses to an e-mail account 
very quickly. The PDF prevents this by requiring the user to either e-mail the form results as 
an attachment or print the form and submit the paper version through mail or fax. The PDF 
form also allows digital signatures and encryption of the form, making it the standard choice 
for secure transmission of more sensitive information. The disadvantages are that the user 
must own the Adobe Acrobat 7 Pro or later. This means that the user must spend several 
hundred dollars before beginning to make forms. The user must also make sure to purchase 
the Professional version of the software – the standard version of Acrobats 7, 8, and 9 are not 
built to support form creation. 
 
At its simplest, forms can be created directly in Acrobats 7 through 9, but the best way to edit 
and create PDF forms is to use Adobe LiveCycle Designer, a companion program to Acrobat 
that comes with the purchase. 
 
B. Creating a PDF form 

Step 1. Open a PDF in LiveCycle Designer. 
To open LiveCycle Designer, go to the Start button (on PC) or Application folder (on Mac) and navigate to 
the Adobe folder. There you should find Acrobat and in the same folder will be Adobe Designer. Click to 
open the program and then open the PDF you will turn into a form. The New Form Assistant dialog box 
will come up and ask to specify the PDF you wish to convert. Click next, and then select Preserve 
Appearance on the next screen. Click next again, and then select the return method you would like to be 
used with this form (submitted by e-mail, printed, either/or). Click next, and if prompted enter an e-mail 
address to send the file to. Then click finish. If a Missing Fonts dialog box opens, press OK. 
Step 2. Inserting fields. 

Inserting fields in Adobe Designer is just as 
easy as in Dreamweaver. From the Insert menu 
at the top of Designer, go down to Standard 
and click on any of the types of inputs to insert 
a form input. You can then move the input to 
the correct location by clicking the input and 
then moving it with the mouse. Please note 
that by default the input will have a label 
attached with it that you will want to remove. 
Click the text that appears to the left or right of 
the input and delete it to remove. 
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Step 3. Finalizing the form. 
Modifying the name, appearance, and default 
values of the inputs can be done from the Object 
tool box (open from the Window menu if you do 
not see the object toolbox). The Layout and 
Border toolboxes are also useful to laying out the 
PDF as you want it to appear. 

 
Once you are finished putting the inputs on the 
page(s), save your work. This creates a new PDF 
file that can be put on a Web server and then 
attached as a link to a page on your Web site or e-
mailed to users to fill out. If you need help with 
these steps, call the Instructional Technology 
Center at 731-881-7877. 

 
 
 
 
 
 
 
 
 
 
IV. Resources 
World Wide Web Consortium info on HTML forms: http://www.w3.org/TR/html4/interact/forms.html 
Adobe Dreamweaver: http://www.adobe.com/products/dreamweaver 
Adobe Acrobat Pro: http://www.adobe.com/products/acrobatpro/  
 


